AARoads Forum

Meta => Suggestions and Questions => Topic started by: SoDakInterstateEnthusiast on May 05, 2020, 11:37:11 AM

Title: Flickr photos not showing up
Post by: SoDakInterstateEnthusiast on May 05, 2020, 11:37:11 AM
Here is an example:

(https://live.staticflickr.com/65535/49856203858_425f5b9572_k.jpg)

It's invisible here, but if you press quote you can see that a perfectly reasonable image url is shown here. This now happens anytime I attempt to BBCode embed any photo. Hopefully you all can figure out what's up...
Title: Re: Flickr photos not showing up
Post by: 1 on May 05, 2020, 11:43:43 AM
Copying and pasting the URL into the address bar returns file not found, so it's not the fault of this forum. (It could still be Flickr's fault.)
Title: Re: Flickr photos not showing up
Post by: kphoger on May 05, 2020, 12:33:32 PM
I replied in the other thread.

It appears you grabbed the URL before changing the privacy settings, which means the URL is no longer valid.
Title: Re: Flickr photos not showing up
Post by: SoDakInterstateEnthusiast on May 05, 2020, 12:42:54 PM
I replied in the other thread.

It appears you grabbed the URL before changing the privacy settings, which means the URL is no longer valid.

Dang it. I really don't want those made public on Flickr.

Also, I switched my SD-45 drawing picture back to private after I posted it, and it still shows up. Why are these 3 specifically not showing up?
Title: Re: Flickr photos not showing up
Post by: kphoger on May 05, 2020, 12:49:58 PM

I replied in the other thread.

It appears you grabbed the URL before changing the privacy settings, which means the URL is no longer valid.

Dang it. I really don't want those made public on Flickr.

Also, I switched my SD-45 drawing picture back to private after I posted it, and it still shows up. Why are these 3 specifically not showing up?

You don't have to set them to public.  You just have to use the new URL that was generated after you changed the privacy settings.
Title: Re: Flickr photos not showing up
Post by: SoDakInterstateEnthusiast on May 05, 2020, 01:14:11 PM

I replied in the other thread.

It appears you grabbed the URL before changing the privacy settings, which means the URL is no longer valid.

Dang it. I really don't want those made public on Flickr.

Also, I switched my SD-45 drawing picture back to private after I posted it, and it still shows up. Why are these 3 specifically not showing up?

You don't have to set them to public.  You just have to use the new URL that was generated after you changed the privacy settings.

Except that when I press the share button when it is private, I only get options for "email" and "share". When I press the share button when it is public, I then also get the option for BBCode. As a result, I temporarily turned it public, got the BBCode deal, posted it, then turned it private again.

EDIT: also I didn't see your post on the other thread until just now, and the steps seem a lot clearer there, however, the issue still remains: Flickr doesn't let me use BBCode if it's set to private.
Title: Re: Flickr photos not showing up
Post by: ozarkman417 on May 05, 2020, 01:28:02 PM

(https://live.staticflickr.com/65535/49860180922_9058c3b64c_m.jpg)

The image I have above is private, though I found a way to bypass it. Click 'embed' then "Embed photo with guestpass" and it will give you a line of code. Paste the code, and within that code is the valid URL. Remove all the code EXCEPT the valid url.
Title: Re: Flickr photos not showing up
Post by: kphoger on May 05, 2020, 01:53:31 PM
I don't know what the problem is.  Here's what I see on a private picture of my own.

Viewing privacy = Private
(https://i.imgur.com/azAsTcs.jpg)

About to click the "Share Photo" icon
(https://i.imgur.com/CdjRdDQ.jpg)

"Embed" or "BBCode" options show up just fine
(https://i.imgur.com/BlP7Cjg.jpg)